0

I'd like to know how to remove automatic

wrapping tags that outputs in page.

<p class="summary">{sous_titre}</p>

This is what I wrote inside my template. As you can see, I already put myself a

tag with a class summary. But in the code source of my page, this is what I get

<p class="summary"></p>
<p>My text bla bla bla</p>
<p></p>

I really don't understand that messed up right there. Tho, I just wanted to output what's inside my wygwam..anyway, so I did some research around forums and found out that I should go in WYGWAM advanced settings and set autoParagraph to No. I did that and I still get the same f%^&* results.

Can anyone fixed this once?

Thx

1

Sounds like the parameter text_only="yes" should sort you out. Documentation.

4
  • I vote this as the correct answer. (Sorry JChrono)
    – Blatant
    Jun 19 '15 at 16:30
  • Wow. How did I pass through WYGWAM documentation without seeing it? Thanks a lot, this will help me a lot in many many many projects. Great answer! Jun 19 '15 at 18:23
  • It's ok, I derped. Just glad someone got it!
    – jrothafer
    Jun 19 '15 at 18:24
  • Matthieu Boisjoli, don't worry, you wouldn't believe how many times I went through the documentation before spotting it. Jun 22 '15 at 9:46
1

You might go about this using an add-on, using CE String or free add-ons, Remove HTML, SuperGeeky Tag Stripper.

I use CE String personally, but the others will do just as well.

0

Channel Field Preferences

Take a look at that channel field's settings. You need to edit this section to be "None". When you change it, make sure you say yes to reformatting all of your entries for channels that have that field group assigment to fix previous entries. To be safe, back up your channel_entries data tables before making this change.

But this will allow your text fields to output without p tags!

3
  • does this work? I waqs under the impression that WYGWAM puts surrounding <p> tags into it's saved value, prior to the Default Text Formatting thing?
    – Blatant
    Jun 19 '15 at 14:16
  • Oh yeah lol.. @Matthew, just switch your field type to a regular (non-rich) textarea!
    – jrothafer
    Jun 19 '15 at 14:49
  • This isn't working. However, I thank you for your time and your answer. I accepted an answer which was found in WYGWAM documentation, pretty easy! Jun 19 '15 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.