0

I'm using Low Search 2.1.2 on a Shop page. The search works fine, but the padlock for the SSL cert is coming up as broken. Inspecting it in Chrome gives the following error: The page at example.com was loaded over a secure connection, but contains a form which targets an insecure endpoint 'example.com'. This endpoint should be made available over a secure connection.

It seems to be Low Search form, which is creating the following HTML:

<form id="main_search" method="post" action="http://example.com/index.php">

I've used the following tag to generate the form:

{exp:low_search:form form_id="main_search" collection="products" search_mode="all" result_page="/shop/results" force_protocol="https"}

Is there a way to make Low Search generate a secure action URL?

1

The following is true for any form generated by EE, including the Low Search form:

If you want the action url to be https, make sure the URL to the root directory of your site setting under Admin > General Configuration (aka the site_url config item) also starts with https.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.