0

I have inherited a newly designed web site that was built with EE and we recently migrated to a Dedicated Virtual Server and upon moving the site, all of the pages are accessible and log in to EE appears to be fine.

However, any attempt to get to to the home page comes up with a blank page that has a message on line 3 that says 'is a guest'. There is no splash page or message that I can find in the code at all that would cause this message and apparently some type of a redirect...or at least not allowing view of the main page.

As if the EE is expecting someone to sign in...but I can get to the admin page fine.

Anyone have any clue why I am seeing this and what I can do to fix it?

Thanks for any assistance.

0

Sounds like possible broken index.php, and since you just migrated, I'd bet the farm on an ill file transfer. Have you tried re-migration? If your templates are stored in the DB and not as files, it's possible you have a failed database migration (the template table may be corrupt), or if you save templates as files, your file could be corrupt.

Head on over to your

/var/www/system/expressionengine/templates/your.default.template.group/

and look at index.html file. Can you paste it's template contents (you can remove most of the HTML elements or use pastebin to present it).

Edit

After checking out your template... It's behaving exactly like it's supposed to. If you're not logged in, all you should see is "is a guest". My first guess is that somehow your default template group got changed (do you have more than one template group?). If someone else did this migration for you, they screwed you on set up. From your pastebin, I would at least fix this line:

{exp:member_categories:categories username={logged_in_username}}

becomes

{exp:member_categories:categories username="{logged_in_username}"}

I'll be honest, this looks like somebody's test template, and not at all like the index page of any production website. You should really go back to your third party migration team and ask them what the hell they did, because that template is not the homepage of a production site. Is it possible your template folder originally lived as a git repo, and somehow a very old commit was checked out?

Member Group 3 is the Guests group. Have you tried logging (the Control Panel) and returning to your index page tosee if that page gives your channel entry loop?

8
  • I'm learning EE...and not trained well. I wasn't even sure where to look. I found the template.group and code. There isn't enough room to paste the code here to look at (if that is what you were referring to...) – wjrapp Jul 7 '15 at 14:01
  • Please use a tool like pastebin.com to paste your code so I can try and assist you. Paste it their, and share that URL in a comment here. – jrothafer Jul 7 '15 at 14:11
  • The migration was done for us. I used an ftp connection to send up new files yesterday. The 'is a guest' message is now, it's now a totally white screen. I can get to the admin page and log in, but none of the data displaced is current as of yesterday. I'm not certain where to go from here... – wjrapp Jul 7 '15 at 14:12
  • pastebin.com/1hM8h8L5 – wjrapp Jul 7 '15 at 14:18
  • Hahaha...yeah..I've had that thought many a time, but few believe me. This site was literally thrown together without much care about content or functionality...and I got stuck with it. I've created and worked on web sites for 15 years and this is my first time I ever had to use a CMS and I know very little about it. It was done on purpose, outside company and they fully expected to keep it on their server and manage/maintain for a cost. That didn't happen, now it's mine and I can't get past this part. – wjrapp Jul 7 '15 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.