0

enter image description hereI'm trying to get Channel From working with non logged in users. Unfortunately with no success. I have

{exp:channel:form channel="calendar_events" return="site/index" logged_out_member_id="3"}

When I try this logged in - it works. When I'm logged out - it says

The provided member id to use for guest submissions is invalid.

Does anybody experienced these problems with channel form and anonymously posting en entry?

p.s. I allowed the Guest submission in the CP admin -> Channel Form page.

  • Did you resolve this? Would be useful to post the fix if you fond it :) – paulcripps Nov 30 '15 at 22:17
2

In addition to this I beleive you have to allow the group access to the specific channel you want them to post too. I just tested this on my sandbox...

So after you've done your thing in Admin > Channel Administration > Channel Form, head over to Members > Member Groups, click 'edit group' for the Guests Row, scroll down to the "Channel Assignment" section (quite near the bottom) and for the channel they are posting to select 'Yes'.

I beleive this should get you rocking, let us know if there's any more issue!

| improve this answer | |
  • Yeah, sure I did this - thank you for noticing, but this still comes with the same error message. Here is the page from the member group settings – Vladyn Jul 10 '15 at 11:19
  • Aha, the plot thickens! Have you got an author field in your channel form? (A snippet of your form might be useful here), also have you tried without logged_out_member_id="3"? I believe this parameter might be forcing the author to user 3, who isn't a guest, obviously. What group is user 3 a member of?? – Blatant Jul 10 '15 at 14:41
  • I'm noticing the fact that I'm actually hardcoding the author id in the hidden fields. And yes I did tried without the logged out parameters – Vladyn Jul 12 '15 at 8:59
  • Actually I have author_id field which is set to "1" in hidden fields on different layer. But I don't think this is the problem at all. Removing the logged_out parameter doesn't work as well. member group 3 is Guests, my member, which is set to author of the post is from this group – Vladyn Jul 12 '15 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.