0

We have an MSM site with five websites and CE image working correctly on all of them. We just added a new one on a subdomain, but images do not appear on the site and are not saved to the "made" directory.

Here's what we get when debugging:

CE Image debug: Base path: '/chroot/home/mydir/mysite.co.uk/html/'
CE Image debug: Source image: 'http://mysubdomain.mysite.co.uk/assets/uploads/myimagename.JPG', Fallback image: ''
CE Image debug: Regexed source: '/home/mydir/mysite.co.uk/html/teachers/assets/uploads/myimagename.JPG'
CE Image debug: The image '/chroot/home/mydir/mysite.co.uk/html/images/made/1eba60a09cddb1ec/myimagename_40_40_c1.JPG' is cached.

Base path is not correct. We've made the changes for MSM configuration on our config.php file just like we did on all previous websites but doesn't seem to be working. However, source image url and regexed source path are correct. But our "made" folder is empty and its path is wrong. Folder permissions seem to be correct and have been triple-checked.

We discard a template problem because we're using the same code across all the websites on the msm setup.

We're hosted at Nexcess, using EE 2.9.2 and CE Image 2.4.5. We need to fix this to go live, so any help is most appreciated! Thanks in advance!

6
  • Hey, can you reformat your question a little bit? You can use either backticks ( ` ) or use a newline with four spaces in front of it to indicate code/important points. I'm just not easily reading through your (Variable) : (Path) pattern in your answer. Please use the Rich Text editor to make things clearer. Sorry, I'm not trying to be a jerk, just trying to help you!
    – jrothafer
    Jul 13 '15 at 4:07
  • Thanks for the feedback! Let me know if it's easier to read now.
    – Farmer1
    Jul 13 '15 at 7:45
  • Wait, '/chroot/home/mydir/mysite.co.uk/html/' is not your basepath, but '/chroot/home/mydir/mysite.co.uk/html/images/made/1eba60a09cddb1ec/' is the correct made path?
    – jrothafer
    Jul 13 '15 at 14:42
  • Source Image and Regexed Source are correct. Base path and "made" folder path are wrong.
    – Farmer1
    Jul 13 '15 at 20:34
  • "We've made the changes for MSM configuration on our config.php file." Do you mean you've followed the options outlined here: causingeffect.com/software/expressionengine/ce-image/user-guide/… ? Jul 13 '15 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.