0

I have the pre-populated fields working but it doesn't seem to work for custom fields. This is the code that I am using. I am mapping the custom member field to the custom field in store but it's not pulling in the info. The other ones I set up worked but they weren't custom. Any thoughts?

<div class="control-group {if error:order_custom2}error{/if}">
    <label class="control-label" for="order_custom2">Cell Phone</label>
    <div class="controls">
        {field:order_custom2} {error:order_custom2}
    </div>
</div>
1

To pull in data automatically you need to make sure that you have mapped your order_customX fields to member fields in the Store > Settings > Order Fields.

Once you have done that you will need to make sure that the user in question has completed an order since they are mapped. If you have added them to your template with an item in already in the cart you will need to empty your cart and add a new item to the cart to reload the member data.

If after that it still does not work:

  • What version of EE and Store are you using?
  • Check the Member > View All > Member Account in question > Edit Profile to see if the data has been mapped and is displayed
  • Try adding just {order_custom2} to the template to see if is outputting data properly.
3
  • hmmm, now I've got it pulling in the custom fields but not the default ones. And they are not populating the member profile info at all. I'm using EE v 2.9.2 and store v 2.5.1 Jul 28 '15 at 23:29
  • Are all of the fields mapped to your custom member like iamjustinlong.com/images/uploads/blog_images/Safari.png ? Jul 29 '15 at 21:49
  • ah, you were right the first time. I had the same names applied to the order fields as the custom member fields and I guess that breaks things. Working now :) Jul 30 '15 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.