0

In the docs if I want the search to include all of the words it says:

Use the ampersand as the separator like this: pie&&cheese.

When I use it, it defaults with a "+" not "&" so how do I change in the search form? It works in the URL (If I change manually) so this is all I need to complete.

Thanks Guy

  • solspace.com/software/expressionengine/super_search/docs/… ... it searches inclusively by default.. – jrothafer Aug 29 '15 at 21:35
  • The problem is, the URI from default is: search&artists_tags=Classical+soloist&band_price-to=&category=/ so there is a "+" in the URL but I was "&&" - so it would look like search&artists_tags=Classical&&soloist&band_price-to=&category=/ – user1840204 Aug 31 '15 at 9:22
  • 1
    A quick comment on your issue. I initially implemented Solspace search on a large website and I was having issues similar to yours. This is not a bash against Solspace (I use other add-ons from them), but I've found that Low Search has all of the bells and whistles you're looking for. Also, Low is much more responsive when it comes to resolving issues with his add-on. I was even able to hire Low to develop a custom search extension - he turned it around in less than a day. – Vaughn D. Taylor Sep 3 '15 at 15:37
0

Keyword searches are inclusive by default (whether or not you see the + or &&), unless disabled with the inclusive_keywords parameter, but there isn't a way to automatically make custom field searches inclusive, aside from having the user actually type && instead of space(s).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.