0

I have a somewhat puzzling situation where Solspace Supersearch (v.2.2.3, EE v2.10.1) times out on very specific search terms. I have tried running the SQL queries corresponding to the same search terms directly from mysql command line and these return pretty quickly (and the number of results is ~30, so this shouldn't be an I/O issue). I've also tried clearing the search log, but that didn't seem to help. I did notice that CPU usage goes through the roof for these searches, mainly for httpd but also for mysql. There doesn't seem to be anything unusual about the search terms that cause the timeouts, e.g. "chili festival" (but NOT "chili peppers").

Any pointers on how I can start debugging this?

Misha

  • Do you have fuzzy searching turned on? That can take up resources as it's trying to match results based on typos, plural/singular, etc. Try turning that off, clear Super Search cache and see if it helps. – Solspace Sep 1 '15 at 2:26
  • Thank you for your response. Turning off fuzzy search definitely helped. I am still puzzled though by the fact that I ran the "fuzzy" queries -- the ones with a series of ORs for all the versions of the search terms -- through mysql command line and that worked fine, but the whole process timed out when run from the browser. Is there something in the query building process that I need to optimize? – Misha Avrekh Sep 1 '15 at 16:14
  • Before "fuzzy" queries are made, Super Search needs to process fuzzy data, i.e. find, create, store the various permutations of the keyword. This might be where the slowdown is happening (hard to say which words make this process "harder" though), which you won't see by running the raw query based on the completed fuzzy data-building process. – Solspace Sep 2 '15 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.