2

I'm getting the same error as this question:

Fatal error: Call to undefined function EllisLab\ExpressionEngine\Library\Mime\finfo_open() in /home/foo/bar/EllisLab/ExpressionEngine/Library/Mime/MimeType.php on line 117

There are two suggestions offered (originally from an Ellis blog post):

  1. Login to your CP and go to Tools, then Utilities, then PHP Info. If you see --disable-fileinfo on that page (I recommend using your browser’s search function) then you will need to contact your host and have them provide a version of PHP with fileinfo not disabled (i.e. enabled).
  2. Check your system/expressionengine/config/mimes.php file. If it does not contain $whitelist = array around line 31 you will need to upload a fresh copy.

... but I've checked both of those, and I'm still getting the same error. Any other suggestions?

I'm in a fresh install of EE 2.10.1, on a Dreamhost server running PHP 5.6.10.

4

I just encountered this, and found that I had to follow the instructions in this Dreamhost wiki entry to truly enable fileinfo functions. (The default "shared" fileinfo support didn't cut it.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.