0

I upgraded Wygwam 2.7.0 to 3.3.3. I run module update and I cleared my browser's cache. I am getting the next errors:

Uncaught SyntaxError: Unexpected token ILLEGAL (ckeditor.js)
config.js:10 Uncaught ReferenceError: CKEDITOR is not defined (config.js)
wygwam.js:134 Uncaught SyntaxError: Unexpected token ILLEGAL (wygwam.js)

Also I am getting the next error 9 times:

Uncaught ReferenceError: Wygwam is not defined

The files ckeditor.js and wygwam.js are being loaded, so that should not be the problem. I read Channel Images could interfere with Wygwam, but I am not using that. Any ideas on this?

Edit:

I turned off all extensions and removed all modules. That didn't made a difference.

I changed the code in ckeditor.js, but the code did not update in the browser.

After that I changed the file names to ckeditor-b.js and wygwam-b.js and referred in the code to the new files. After this change the new code loads in the browser and the errors I first had, disappeared. But now I have new errors. All of the new errors refer to paths that don't exist.

Edit 2

I reversed the changes I made in Wygwam.

I guess I need to use a timestamp like specified in this link. I tried it by placing it in config.js, but that file does not load in the first place because ckeditor is undefined. Where would the correct placement be?

  • if site online - send me a message to max at eec.ms and I can look. – Max Lazar Sep 15 '15 at 18:19
  • I made this change on my development environment. Like this I can't put it online. Users depend on working in Wygwam. – Balloonatic Sep 16 '15 at 6:19
3

Did you just upload the folders and have them over write the existing ones? If so, this doesn't always work well, especially with a large addon like WYGWAM. Try, deleting the folders on the server and uploading them fresh.

| improve this answer | |
  • First I deleted the old Wygwam files. I work in SVN so I also committed the deleted files before I copied the new files. – Balloonatic Sep 2 '15 at 12:35
  • what version of EE? – Jim Wyse Sep 2 '15 at 14:35
  • Ee version 2.9.3. – Balloonatic Sep 3 '15 at 5:59
1

I finally solved it by completely uninstalling the Wygwam module!

Follow the following steps to do it safely:

  1. Make a dump of your database, so you can restore data if needed. You also need this, to restore Wygwam configurations.
  2. Also make sure you have an example of the Wygwam configurations, so you can verify if the configurations are correct. I had an example on my development environment.

  3. Change the name of field_type of channel_fields in your database with a sql-query, so it will be safe to delete the module:

    UPDATE exp_channel_fields SET field_type = 'wygwam-2' WHERE field_type = 'wygwam';

  4. Uninstall the module in add-on->modules

  5. Remove the module from your file system. Don't forget to also delete Wygwam from the themes folder.

  6. Empty the cache in tools->data->empty cache

  7. Add the latest version of Wygwam to your file system

  8. Go to add-on->modules and install Wygwam

  9. Restore the name of the Wygwam fields with a sql-query:

    UPDATE exp_channel_fields SET field_type = 'wygwam' WHERE field_type = 'wygwam-2';

  10. Take and perform the piece of code from you sql-dump to restore the exp_wygwam_configs table.

  11. Check the Wygwam configurations in the CMS. If needed adjust settings.

And you are all set.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.