I have just used EE's native image manipulations for the first time and boy did they work great. However, my client looked at the site after I replaced the old images with the resized ones and her nice white backgrounds on products no longer looked white. It's very subtle, I have to look at my monitor at an angle to see it, but apparently it is quite noticeable on certain monitors. When I color sample these white backgrounds, I get an occasional #fefefe pixel. So on some monitors, it is giving the whole image background a yellow cast. I'm wondering if anyone has advice about increasing the quality of the image manipulations, or other ways of managing this particular problem. I see that I can specify a different library, but it's unclear to me if that would help. The images are jpg and I imagine that increasing the quality of the jpg might help, but I don't see settings for that.

2 Answers 2


By default I think EE sets the quality of the image at 90

You could try editing system/codeigniter/system/libraries/image_lib.php LINE 36 and change the var $quality to 100

Other than that if you are using GD2 Image Resizing Protocol, try switching it to ImageMagick (if on your server) which may give a slightly better result.

  • Thank you! This is just what I was looking for. Will report back. Commented Sep 10, 2015 at 2:10
  • Just changing the quality didn't do it, but switching to ImageMagick + the quality setting did. I haven't tried ImageMagick at 90, but I'll probably just leave it as-is. Commented Sep 10, 2015 at 16:53

I've seen odd things happen with images when the color profile is set to something other than sRGB. Check to make sure the color profile is using sRBG and not something like Adobe RBG or ProPhoto RBG. If you're using any type of Save for Web feature it will usually set the color profile to sRGB automatically.

  • Thanks for that. Both the original and the re-sized image do come up as sRGB. Commented Sep 9, 2015 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.