0

The problem I'm having is that the data in my Grid field is not influencing the search results.

I have two channels, one of which has a grid field. The field and the relevant row are both marked as searchable.

I've created two Collections, one for each channel, where the weight of the grid field is set to 3.

My template code doesn't use a collections parameter, so I believe it should search both channels?

Yes, the entries were there before I marked the fields as searchable, but I've since re-saved one entry so that it would populate the exp_channel_data table, and re-indexed the Collection so that I could test the search, but I'm still not getting that entry in the results.

Have I missed something else?

0

Things to check:

  • is the content actually in the exp_channel_data table?
  • is the searchable content actually in the exp_low_search_indexes table?
  • enable the template debugger and look up the lines that mention Low Search; does that give you any insight?
  • enable the output profiler and look up the query generated by the Keywords filter. What happens if you run that query manually (in Sequel Pro or PhpMyAdmin)?

If, for the latter, the query is present, but renders no results, then it could be that there is not enough data in the database in order for the fulltext searches to work properly. I also recommend to only give a high weight to small fields, like titles or text inputs. For fields that contain larger amounts of text, like textareas or Grid fields, setting the weight to 1 should suffice.

| improve this answer | |
  • Thanks for this, Low. I may have wasted your time - I made a silly mistake: I added a channel parameter to the results tag. When I removed that, the entry with the grid field showed up in the results. There is another issue I'm having when I remove it though. I have a relationship field linking one of those channels to the other, and although I do want fields from both channels to be searched, I only want entries from one channel to appear in the results. It's kind of hard to explain, so I'll think about how to word it better and maybe I'll post again. Thanks for your help. – Mike Mella Sep 24 '15 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.