0

Is there a conflict with Solspace Calendar and Twitter Bootstrap 3.3.4? When I enable the date picker field on the channel form, the navigation loses all formatting from Bootstrap. I see current documentation calls for jQuery 1.3 while the new Bootstrap is using 1.11.2. Is there a way to have both?

2

This is because Calendar uses ExpressionEngine's built in jQuery UI bundle to build the mini calendar popup. You will probably have to use some combination of the two with jQuery's noConflict method: http://api.jquery.com/jQuery.noConflict/

| improve this answer | |
0

So the fix for now.... (Which has been fixed for Donovan) seems to be the following....

HISTORY: $.browser property is deprecated in jQuery 1.3, and bootstrap requires jQuery 1.9.1+ (Or similar)

SOLUTION: For some unknown reason this causes an issue when using Solspace Calendar with Twitter Bootstrap...(I assume there is a correlation in the Module and this depreciated plugin)

After loading jQuery.... add in the Script for the jQuery Migrate Plugin. (See following)

<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script>   
<script src="http://code.jquery.com/jquery-migrate-1.2.1.js"></script>

Hopefully this will help! (Only put the answer for other's to see, in case someone else had this issue.)

SOURCE FOR JQUERY MIGRATE: JQuery Migrate

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.