0

One of my channels has a Wygwam field set to use the "Basic" formatting toolbar. Whenever I save an entry, and then go back in to edit that entry, the word "Schedule" appears as the last line in the Wygwam field. I have no idea where this word would come from.

I have other channels using Wygwam, some of them also using the "Basic" toolbar, but this doesn't happen in those channels.

I don't have any advanced settings or style sheets added to this particular Wygwam field, and "Restrict allowed HTML" is set to "Yes".

I've temporarily changed the toolbar to a different one and that seems to have resolved it for now.

Ever seen this?

EDIT:

I just noticed in the Source view of Wygwam, this code is being written into the field:

<p><button class="tw-schedule-btn" id="tw_schedule_btn" style="padding: 4px 6px;position: absolute;left: 141px;top: 840px;background-color: #F7F7F7;  background: linear-gradient(#FFF, #F0F0F0);  border: 1px solid #CCC;  color: #5F5F5F;  cursor: pointer;  font-weight: bold;  text-shadow: 0 1px #FFF;  white-space: nowrap;border-radius: 3px;font-size: 11px; display: none; z-index: 8675309"><span>Schedule</span></button></p>

I may be able to figure this out myself soon, but anyone recognize that? From some sharing button maybe?

  • Does "schedule" have anything to do with the channel? For instance, is that word used in any other fields, field instructions, etc.? – Matthew Oct 26 '15 at 16:56
  • Not that I can see. – Mike Mella Oct 26 '15 at 20:15
2

I encountered the exact same issue with the CK text editor in ColdFusion, with the same code automatically inserting itself. In my case it turned out to be a browser extension called Tailwind. This is a scheduling tool used by Hootsuite and other social media automation tools. Disabling the extension fixed the problem. I was using a Mac with Safari as my browser. I don't know if this would behave the same on other systems or browsers, but I hope this helps.

| improve this answer | |
  • You're totally right. My client did figure out that it was an extension, but I wasn't sure which one. But she uses Tailwind all the time. Thank you! – Mike Mella Feb 4 '19 at 15:20
0

My first guess was that there was something weird with field names or instructions, and maybe accidentally unclosed HTML tags, that was causing this. But if the word "schedule" isn't otherwise associated with the page, I don't see how that could be it.

My second guess would be something browser-based, such as an autocomplete add-on or something similar. Have you tried using a different browser, and/or a different computer?

| improve this answer | |
  • Yes, this was brought to my attention by my client who has a team of editors all also experiencing this. I've edited my original post because I've found some code that looks a lot like some kind of social sharing button being written into the DOM. I'll poke around some more. – Mike Mella Oct 27 '15 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.