0

While using the EE 3.0.2, I got this trash inside a variables, when using for example {exp:channel:categories} or {exp:channel:category_heading}

Ex:

{exp:channel:category_heading}
<h1> my free text here  {my_category_field} </h1>
{/exp:channel:category_heading}

But when I'm viewing my result, I see this:

<h1> my free text here <p>category field value</p> </h1>

There is a format field option in adding new field for categories, when I'm creating a field, I'm choosing no format at all, but when I'm going to edit the options of created field, I see the "XHTML" selected option there, which I can't change to something else. I think this trash "p" tag is going from here. What should I do to destroy this bug?

0

It's a bug (#21272) that's been fixed in EE 3.03.

0

What should I do to destroy this bug?

... start by verifying it's a bug, and then report it to EllisLab. This is a common issue with EE (people finding the <p> tag inserts in formatted fields) but usually setting the field format to None fixes that. Did you edit the field and verify its setting?

Head on over to your

system/index.php?/cp/channels/fields/edit/XXX

page (XXX is your field_id) and verify that it's Text formatting is set to None.

7
  • Yes, just as I wrote. It's admin.php?/cp/channels/cat/edit-field/1/2 for my bug, and yes it's a bug of new EE 3.0.2 – morgan chester Nov 4 '15 at 14:20
  • Hrmm. I'll do some testing and see if I can recreate the issue. It's possible that a manual change to the database row for that field will fix the issue, but if it is a bug, I'm surprised I haven't run into it yet. – jrothafer Nov 4 '15 at 14:25
  • there are a lot of bugs for the new EE; For example, in yesterday-downloaded version I can't change the chosen template for the entry within the pages module options. It's changing only when I'm changing something else in a text of fields, for example. – morgan chester Nov 4 '15 at 14:37
  • Oy! I don't have EE 3 in the wild anywhere yet, just mostly 2.9+, so I'm only playing with it. I generally never adopt new full version changes for a long time, but I don't think they give new licence purchasers a choice, you have to use EE 3. – jrothafer Nov 4 '15 at 14:43
  • All EE3 purchases come with a valid EE 2.10.1 license and download. – Derek Hogue Nov 4 '15 at 14:50
0

So, until it's a bug, we need a common decision for it. I made this:

<h1>My custom text <?=strip_tags('{my_category_field}')?></h1>

and turned on PHP-parsing on closing for that template. Dumb, but this works for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.