1

Am trying to install Flag Master addon.

https://github.com/mithra62/flag-master

Did copy the extracted folder to third_party folder as per the install instructions.

However the module doesn't show up in the modules list for it to be installed.

Am using EE 2.10..1

Any pointers?

Thanks

1
  • Am using EE 2.10.1 – Noor M Nov 20 '15 at 13:48
1

The files should be located inside system/expressionengine/third_party/flag_master/ folder, not directly in third_party folder. Please check that.

5
  • The files are in the 'flag-master-master' folder inside 'third_party' folder Yuri. – Noor M Nov 20 '15 at 15:40
  • I renamed the folder 'flag-master-master' to 'flag_master' and it worked! – Noor M Nov 20 '15 at 15:41
  • However, after installing, and when trying to access Flag Master module, there is an error. Unable to load the requested class: flag_master_member_data – Noor M Nov 20 '15 at 15:45
  • Commented line 50 in Flag_master_channel_data.php ' $this->EE->load->library('flag_master_member_data');' Guess the newer versions don't need that! – Noor M Nov 20 '15 at 15:51
  • It still asks for a license key, which I don't have, since it was not downloaded from devot-ee.com and was downloaded from Github. Waiting for the developer Eric Lamb to respond. Will keep you posted. – Noor M Nov 20 '15 at 16:11
1

You will need to make sure the folder you place in the third_party directory matches the package name.

From the Github repo, you can see that the files are called xxx.flag_master.php, so therefore the directory needs to be named flag_master. I assume the because the Github repo is called flag-master, the folder is being named that instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.