0

I am getting a error every time I try and upload an image using channel images.

There's no file size or dimension restrictions in upload preferences, its a simple .jpg about 50kb. Max upload is set to 8mb. tried .png too.

Error: "success":"no","body":"No file was uploaded or file is not allowed by EE.(See EE Mime-type settings)."}

ExpressionEngine 2.9 Channel Images 5.4.19

Any Ideas?

2 Answers 2

0

Is this happening locally or on a host? Can you upload that file via the EE File manager? When I got a similar error (for a larger file) using Channel Images, the fix was to tweak my settings. Here is what I am using:

max_execution_time = 600
max_input_time = 600
memory_limit = 256M
post_max_size = 200M
upload_max_filesize = 200M

or via .htaccess (if your host allows)

php_value upload_max_filesize 200M
php_value post_max_size 200M
php_value max_execution_time 600
php_value max_input_time 600
php_value memory_limit 256M
3
  • Hi, thanks, I have already tried those in php.ini. It's on a server, I can upload them via the file manager. No matter what file with any file size it won't upload. I have also created a new channel image field in the same field group with the same results. Even if I change the upload location. Only in this channel/field group though. I have channel images fields in other field groups that work fine.
    – Mark
    Dec 2, 2015 at 6:36
  • This is by no means resolved, the reason behind this issue was never found. But to get around it I deleted that entry and published the page again. (it was in a home channel, so only one entry luckily.) Not sure if I can mark this as answered??
    – Mark
    Dec 2, 2015 at 8:52
  • So after you deleted the entry, you were able to create a new entry and the upload worked? If so, I would add a new answer with what worked, then you can accept it as the correct one.
    – Todd
    Dec 2, 2015 at 14:19
0

I deleted that entry and published the page again. (it was in a home channel, so only one entry luckily.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.