0

Wiki version 2.3.

Anyone know what the last available version of the first-party Wiki module is for EE2? I have some old wiki living somewhere on a site, and it's pulling this crap:

Error Number: 1064

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 9

SELECT r.*, m.member_id, m.screen_name, m.email, m.url, p.page_namespace, p.page_name AS topic FROM exp_wiki_revisions r, exp_members m, exp_wiki_page p WHERE p.last_updated = r.revision_date AND m.member_id = r.revision_author AND r.page_id = p.page_id AND r.revision_status = 'open' AND r.wiki_id = '1' ORDER BY p.last_updated DESC LIMIT

Filename: modules/wiki/mod.wiki.php

Line Number: 1518

at this address /Special:Recentchanges_Atom. I honestly don't have time to debug something that's pretty damn underused, but it shows up as broken links with our web governance tool, and I just wish to be rid of it. I'm hoping we just missed a sub-version upgrade or something.

1

I get the same error with Wiki 2.3 and EE 2.10.1. That SQL query should specify a number for the limit e.g. LIMIT 10.

The easiest way to fix it is to change the template code for wiki_special_atom.html. Change the line (I'm using the default theme):

{wiki:recent_changes}

to

{wiki:recent_changes limit="10"}

The best way is to fix mod.wiki.php but I don't have time for that either. :)

1
  • Heeeey nice catch. Yea, exactly, I didn't even know there was a Wiki on my site until someone complained, lawl. Thanks! – jrothafer Dec 4 '15 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.