1

here's the problem (edit):

I'm unable to upload some mp3s through the publish page or the file manager, whereas other mp3s would upload just fine. Now, thanks to the assistance of a support person at the host (Nexcess), I've found that the mp3's that don't work didn't have all the encoding they need, and the mp3's that did work had the encoding, like this:

The mp3's that were working look like this:

$ file /dev/audio-upload/*.mp3
example01.mp3: Audio file with ID3 version 2.2.0, contains: MPEG ADTS, layer III, v1, 192 kbps, 44.1 kHz, Stereo
example02.mp3: Audio file with ID3 version 2.2.0, contains: MPEG ADTS, layer III, v1, 192 kbps, 44.1 kHz, Stereo
example03.mp3: Audio file with ID3 version 2.2.0, contains: MPEG ADTS, layer III, v1, 160 kbps, 44.1 kHz, Stereo

The mp3's that weren't working look like this (they're missing the encoding info):

$ file /dev/mp3s-for-eval/*.mp3
example01.mp3: Audio file with ID3 version 2.2.0, contains:
example02.mp3: Audio file with ID3 version 2.2.0, contains:
example03.mp3: Audio file with ID3 version 2.2.0, contains:

So a solution was to re-convert the unencoded files to mp3. But the problem remains: the mp3's that wouldn't upload (the ones missing the encoding info) play just fine. Is there a way to get EE to allow these un-encoded mp3's so my client doesn't get confused if they have files like this?

Also, these test mp3's that didn't upload were created by converting AIFF files in iTunes; any ideas as to why they didn't get the encoding?

(this is my original question:)

I'm having a mysterious time trying to get certain mp3's uploaded through a Grid field.

I'm developing a music site using EE 2.10.1; one of the channels is "Albums" which holds info on different music CDs. In this channel I have a Grid field that contains info about the different tracks on the CD and also the mp3 of the track.

My upload location is set to "all file types" and when I check the PHP info, it looks like the max file size allowed is 64MB.

When I try to upload the mp3's I need for the first entry, I get a cryptic "file not allowed" message; 'cryptic' because it's not saying it's an invalid file type or that the file is too big:

file not allowed screenshot

So I’ve been testing to see what I can--and can’t--upload. I've been able to successfully upload a 13.7MB jpg through the Grid field, so I'm assuming that size isn't an issue (the mp3's are all smaller than that).

Further testing reveals that I'm able to upload some mp3's, ranging in size from 1.4MB to 8.2MB. But the majority of mp3's I try give me the error message. Also, I've tried uploading the mp3's that don't work directly through the File Manager, but I also get the error message that way.

Any ideas or thoughts about what the problem could be? I have no idea if this is somehow a server issue, an EE issue or an issue with particular files (I can play the mp3's that won’t upload, so I don’t think they’re corrupt).

Thanks in advance for your assistance!

1

Try to disable XSS filtering in your security preferences. It looks like EE flags those files as suspicious.

| improve this answer | |
  • Thanks for this thought, although it doesn't seem to have any effect on the issue. You can see my edit above that explains more about what is happening. – edward Dec 14 '15 at 13:35
0

Following up on this, the issue turned out to be incorrectly created MP3s! I was using iTunes to convert AIFFs into MP3s and for some reason -- even though the MP3s would play -- they were not correctly formatted in some way. Converting the AIFFs with a different program correctly formatted the MP3s and then they would upload. So the problem was that EE was seeing bad file formats, there wasn't any size-limit or anything.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.