0

So I have ExpressionEngine Core Core v2.10.1 - Build Date: 20150501 installed and under localisation I have set to see 24 hour default time formatting and to include seconds in the default time format, but when I go to list of entries, that setting is not applied. I still see AM/PM time and also when I go in the entry and want to change time of publishing for some entry I get an error: "This form has expired. Please refresh and try again." I did put in config.php $config['disable_csrf_protection'] = "y"; but it did not help.

0

You need to change the date formatting options for your members (in this case, I suppose, the Superadmin) as well.

3
  • that was it. I forgot about it. For me that is really stupid solution, if I as admin change some setting, I should be able to save that setting to all users or at least to be warned about possible differences.
    – BSheep
    Dec 14 '15 at 22:37
  • Isn't there an option that prohibits users from using such custom formatting options? That might work. Either way, glad you're up and running.
    – Ingmar
    Dec 15 '15 at 7:48
  • A second thought, I'm not sure how EE Core (i.e., without the Member module) compares to the full version.
    – Ingmar
    Dec 15 '15 at 8:00
0

You can change the localization preferences for all members by setting the following config variable:

$config['allow_member_localization'] = 'n';

EE will then use the fallback include_seconds config variable. I had a similar issue and added the following code to my config.php to solve it:

$config['include_seconds'] = 'y';
$config['allow_member_localization'] = 'n';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.