0

Using EE v2.9.0. and Latest MSM

I created a new category group and created a category called miscellaneous.

I already have a seperate category group with a category called miscellaneous.

This caused a web page to stop pulling through entries when the category in the url was 'miscellaneous'.

As soon as i changed the category_url_title to something else the entries on the web page started to pull through once again.

I searched online and someone said it was a bug? But also said it should be been fixed in v2.4.0 or there abouts.

I saw a post from someone with an even newer version to me claiming they had the same problem.

Does anyone have a fix or a solution other than chaning url_title?

Cheers,

Wes.

0

I think url_title needs to be unique, otherwise how is EE going to know which category to show? I don't really see a way around that requirement.

2
  • surely EE should generate a miscellaneous1 like it does in channel:entries then, as opposed to it letting you create a category with the same url_title. I just figured because it was under a different group and the group is assigned to only one channel that it would work. – Third_Hyperion Dec 16 '15 at 16:15
  • I think it should, but in this case, too, the url_title would be different. You'll just have to do it manually for now. – Ingmar Dec 16 '15 at 17:09
0

Use category_id instead of category_url_title to pull entries. The category url title can be changed manually from category edit page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.