0

I'm using EE 3.0.5.

I have a template: store/location

If there's a third segment, additional information is displayed via a conditional: store/location/coupon

The template route is set to: /location/{coupon:alpha_dash} Require all Segments? = NO

But when I try to access /location, I get a 404 Error.

With the additional segment, /location/coupon, everything works fine.

How do I display the template without the last segment, /location? Shouldn't Require all Segments? = NO allow the url without the last segment?

Thanks for your help.

  • Does your store/location template contain any {redirect="404"} tags? – Derek Hogue Dec 24 '15 at 16:12
0

It might be related not to Routes, but to template/URL rules in general.

If in your template preferences you have enabled 'Strict URLs' then at least 2 URL segments are required.

You can try overriding this by adding special route for /location

| improve this answer | |
  • I think it is due to the Strict URLs and requiring 2 segments. Thanks for your help. – atomicglue Dec 28 '15 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.