IMPORTANT: It turned out that this question couldn't really be answered based on the info I had provided, and it wasn't possible for me to provide enough info to make it answerable. Tom provided the best steps for debugging this type of issue in a normal situation so I'm giving it to him, but in my case the issue being that some changes to core that are not released yet, were causing problems in the way that Secure form processing worked. Turning of secure form processing until this issue is remedied was the solution that worked for me.

The Question

I'm having an issue in my ee2 install in which most often when I edit or create an entry in the control panel and click submit, the control panel homepage is loaded and the content is not saved. If I hit back in my browser and resubmit, the change is saved on the second try.

Has anybody else seen this, and does anyone know what the fix is likely to be?

  • What version of EE are you running? Do you have any extensions installed that might be causing issues? Commented Nov 26, 2012 at 5:28

2 Answers 2


I'd start by disabling all third party extensions, as an errant one of those is probably the most likely cause. You can do this globally in config.php by setting:

$config['allow_extensions'] = 'n';

If this fixes it, set this back to 'y' then disable your extensions in the CP one by one until you find the cause.

It's also worth checking that there are no JS errors on the publish/edit page (using your browser console). If there are these can normally be traced to a custom fieldtype, or some other addon. If you find one and can't debug it yourself post it here.

  • It is too early to tell for sure, but it looks like disabling the MD Character Count extension may have fixed the issue. I'll run with it for a day or two to confirm that I don't run into this anymore and mark this as the accepted answer if all seems good.
    – UltraBob
    Commented Nov 26, 2012 at 9:24
  • I have not forgotten about this, but other things have kept me from fully being able to dig into it. It turned out that disabling those extensions didn't solve the issue, and it also appears that if I save a very quick change it will be saved properly. The timeout for that not working seems to be very short.
    – UltraBob
    Commented Dec 3, 2012 at 7:36
  • I still think it's worth eliminating any 3rd party code, especially as that timeout issue sounds like it might be JS related. Do you have any accessories installed in your CP? Have you tried disabling those as well?
    – Tom Davies
    Commented Dec 3, 2012 at 8:32
  • I hadn't gone as far as disabling all extensions and accessories yet, but as part of trying to figure out the answer to my latest question I did. I'll keep an eye out to see if that fixes it, but I'm not all that optimistic, I didn't have anything complicated in extensions or accessories.
    – UltraBob
    Commented Dec 3, 2012 at 8:44
  • I tend to think the answer to this will be the answer to my other question that you've provided an answer on. I bet redirects are somehow getting in the way of the save. If we get that resolved and it seems to fix this issue as well I'll write up an update to the question explaining what the issue was in my case, and accept your answer as really those are the most sensible first steps to debugging something like this, and not following up on this quickly was on me and my workload.
    – UltraBob
    Commented Dec 4, 2012 at 4:24

It's an XID issue/bug that is known to EL and slated to be corrected in the next release. A fix until then is posted: https://support.ellislab.com/bugs/detail/19920#12050

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.