0

I'm having a problem with EE; when updating or creating an entry I get redirected to the 404 page. I've researched a lot because this is getting annoying. I've tried checking the .htaccess as a common response to this question. My index.php is present and my .htaccess is this:

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /

    # Removes index.php from ExpressionEngine URLs
    RewriteCond %{THE_REQUEST} ^GET.*index\.php [NC]
    RewriteCond %{REQUEST_URI} !/system/.* [NC]
    RewriteRule (.*?)index\.php/*(.*) /$1$2 [R=301,NE,L]

    # Directs all EE web requests through the site index file
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ /index.php?/$1 [L]

RewriteCond %{HTTP_HOST} ^studio24\.24studiohnserver\.com$ [OR]
RewriteCond %{HTTP_HOST} ^www\.studio24\.24studiohnserver\.com$
RewriteRule ^/?$ "http\:\/\/cumminsca\.com\/" [R=301,L]

Seems fine; I also tried with changing the $config['uri_protocol'] = 'AUTO'; in config.php to all the other options, but no luck.

I changed the Force URL query strings option, tried yes and no, no luck. My site's root directory is set to full URL, not "/". I'm using version 2.7.0 of Expression Engine, when enabling the debug option my output is this:

 Template group and template not found, showing 404 page

which is weird. I can't create new entries or make changes, and I haven't done any changes to my site configuration, it just stopped working. My only other guess is the hosting company changed something in their protocols and it's making EE go crazy. Any help with this will be much appreciated.

0

You are getting this error because the requested template is not found in your database. So because of that I don't think it is related to the rewrite rules.

Are you saving your files on your server? Than you can try to synchronize your templates. In your cp menu: design -> templates -> synchronize templates.

  • I did syncronize them,and im saving files as templates. still no luck. – Omar Fabricio Mejia Jan 19 '16 at 14:32
0

Ok so this is for anyone who has the same issue as me, and because i had a hard time finding the solution, ill tell you what i found.

So the problem is a security module some web servers install, thats called "ModSecurity". ModSecurity inspects the activty on the domain and depending on your config, if it sees something weird happening to your DB,it doesn't allow it. thats why i could create new entries or update old ones, only delete.

so my solution was, asking tech support to disable modsecurity, and instantly it worked. just ask them to disable the mod_sec module for your user.

Hope it helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.