0

I am using channel image 5.4.2 and as per docs I trying simple template like":

<html>
  <head>
  <meta charset="UTF-8">
  <title>Document</title>
  </head>
   <body>
      {exp:channel:entries
      channel='articles'
    dynamic='no'
    entry_id='85'
    limit='1'}
    {title}
 {exp:channel_images:images channel="articles" entry_id="85"}
    <img src="{image:url}" alt="{image:id}">
{/exp:channel_images:images}
{/exp:channel:entries}
 </body>

Where I have custom field, called "article images". The problem is that when I add this and try to open the template I'm getting "ERR_CONTENT_DECODING_FAILED" and page breaks.

Actually my end point is to add this in json output and to be able to consume added images json property from the whole json object, which is used for website data.

Does anybody had this issue?

EDIT: Actually what I do need on the front-end is

"article_images" : 
    [
        "/imgs/237455.jpg",
        "/imgs/4H631C00.jpg",
        "/imgs/243224.jpg"
    ]

this to be added as JSON property

2
  • Try putting your {exp:channel_images:images} tag in an embed.
    – jrothafer
    Jan 26 '16 at 14:23
  • Nope - this doesn't work
    – Vladyn
    Jan 26 '16 at 14:40
0

The version 5.4.2 has terrible behaviour and I would say that is not for production use at all. Sorry DevDemon, it's nice add-on but this version isn't that stable. I switched to Matrix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.