2

I really need to get some help on this as I have reached out to EL, The Outfit, DD, etc. All have been helpful and eager to assist, but we can't resolve the issue.

I have never run into issues like this with anything I have ever hosted on Siteground (who is where this client is), but I have never tried to install/run EE3 on any either.

I initially had issues with EE3 alone. One of the issues was a bug and is being resolved in the next release. The other was resolved by updating to 3.1.1. The second issue was with DevDemon's Updater add-on. This was an object reference error, also resolved by fresh install of EE 3.1.1.

I them purchased NavEE to use and upon install, was greeted with a page of errors, warnings, etc. I cannot reproduce the errors on my local dev setup running WAMP. Michael at The Outfit was helpful in checking into things on his end as well. While neither of us were able to reproduce it on our ends, we were able to reproduce it on the SG server. I even provided a zip file of the file system with a DB dump. When rebuilt, the error was not present on local machines.

I then opened up a support ticket with the hosting company. However, they only checked file permissions and made sure the files were present and that there were no PHP error logs. They don't know enough about what requirements, if any were causing the conflict and suggested I get with the CMS/Add-on company again. Once I find out, I will be able to tell them what they need to do.

This is beyond frustrating to say the least. :(

The way to reproduce this issue, assuming you have NavEE, is to attempt to install it. You should be presented with a view file to enter your license. However, I am greeted with this:

Exception Caught
View file not found: mcp/license/index

/home/stkhomes/system/ee/EllisLab/ExpressionEngine/Service/View/View.php:343
Stack Trace: hide details

#0 ee/EllisLab/ExpressionEngine/Service/View/View.php(95): EllisLab\ExpressionEngine\Service\View\View->getPath()
#1 user/addons/navee/mcp.navee.php(36): EllisLab\ExpressionEngine\Service\View\View->render(Array)
#2 [internal function]: Navee_mcp->license()
#3 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(1607): call_user_func_array(Array, Array)
#4 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(883): EllisLab\ExpressionEngine\Controller\Addons\Addons->getModuleSettings('navee', 'license', Array)
#5 [internal function]: EllisLab\ExpressionEngine\Controller\Addons\Addons->settings('navee', 'license')
#6 ee/EllisLab/ExpressionEngine/Core/Core.php(191): call_user_func_array(Array, Array)
#7 ee/EllisLab/ExpressionEngine/Core/Core.php(94): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#8 ee/EllisLab/ExpressionEngine/Boot/boot.php(138): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#9 /home/stkhomes/public_html/admin.php(143): require_once('/home/stkhomes/...')
#9 /home/stkhomes/public_html/admin.php(143): require_once('/home/stkhomes/...') 

The file IS in location and the properties are set properly as well. If there is anyone that can help with this, it would be greatly appreciated. I can provide whatever is needed in information in order to check server requirements, settings, etc.

2

Ok, I don't know what was happening, or why the casing was "off", but the issue was due to the following lines inside of EE's View.php service file:

/**
 * Get the full server path to the view file backing this
 * view object.
 *
 * @return String The full server path
 */
protected function getPath()
{
    $path = $this->provider->getPath().'/View';
    $old_path = $this->provider->getPath().'/views';

    foreach (array($path, $old_path) as $path)
    {
        if (file_exists($path.'/'.$this->path.'.php'))
        {
            return $path.'/'.$this->path.'.php';
        }
    }
    throw new \Exception('View file not found: '.htmlentities($this->path));
}

in which the path is turned to "View". the folder in the NavEE package was named with a lower case "view".

Changing the case corrected the issue.

***Noted:

A. Apache is case-insensitive when serving HFS, but B. points out a security vulnerability where a path of a different case can cause a whole and points out that the presence of mod_hfs prevents this.

| improve this answer | |
  • By the way, much of this was corrected in the newer releases of NavEE. Michael worked with me on this and corrected a few little buggy things. He provided great support. Nothing like a good add-on with better support. :) – W3bGuy Feb 3 '16 at 20:57
0

Are you trying to install NavEE with the updater addon? Or a manual install? If the former, try the latter if you haven't already. The updater can run into permission and ownership problems.

| improve this answer | |
  • My initial attempt was manually. After failing several attempts and trying to debug, I tried Updater first and then using Updater to do it. Different errors, but still no dice. – W3bGuy Jan 27 '16 at 0:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.