0

I'm desperate. I've purchased Forms several times for different clients, and recently upgraded to a developer license since it provides such great functionality for us. I've come up against a problem and emailed their support twice about, with no answer (plus a third time about something unrelated, and no answer to that either....)

My newest client needs conditional logic on their form, and no matter what I try, I cannot get them to work. I am using the Forms fieldtype for a channel. The form shows up correctly, I can make edits to it as needed, I have {exp:forms:output_js} being called in successfully for other forms on the same site (with no conditionals).

EE version 2.10.2, Forms version 3.5.3

I have a checkbox question of: "What times are you available to volunteer?" with the checkboxes / values of:

  • All day / all-day
  • Morning shift / morning-shift
  • Afternoon shift / afternoon-shift

If, and only if, "All Day" is selected, I have a follow up checkbox question ("If you are available all day, which authors would you be interested in assisting?") that I would like to show up. I've turned conditionals "on" for this question, and selected:

Show this field if any of the following match:

Field: What times are you available to volunteer?

Conditional: is

Value: all-day

Doesn't work. I've tried all sorts of changes: switching from "show" logic to "hide" logic, using numerical values instead of alpha, with spaces, without spaces, with dashes, without dashes, radio buttons instead of checkboxes, etc. I've deleted the form, recreated the form, cleared cache, tried on other forms, etc.

I'm at a complete loss - if I can't get conditionals working, I'm going to have to request a refund and find another solution (which I want to avoid, I love everything else about this plugin!)

0

Have you got queue javascript in the form tag

 {exp:forms:form form_name="your_form" queue_js="yes"}

My conditionals never work without that in there. If you do have it in there its probably a javascript conflict

2
  • I had been calling in the form using EE's tax for calling in fields (since I was using Forms as a field on an entry, not as a standalone). However, I gave it a try calling it in manually like this via the form name, and still no dice. I'm going to try to track down any javascript conflicts now.
    – Cassandra
    Jan 29 '16 at 20:23
  • This helped me track down the conflict (I had a snippet embedding a second devdemon form and conflicting jquery calls). Thank you for the additional brainpower!!
    – Cassandra
    Jan 29 '16 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.