1

I am able to upload PDF, TXT, SQL, AI, XLSX, JPG, PNG files using the File Manager as a Super Admin. However, when I try to upload an EPS file, I get a "File not Allowed" error. Mime file has 'application/postscript', // .ai, .eps, .ps in the white list.

-- Does anyone else have any ideas? I have now tried installations of EE versions 1.6.8, 2.1.0, 2.7.0 and they load EPS files with no problems. There seems to be a problem uploading EPS files when I try EE 2.10.2, 3.0.6, 3.1.2. I wonder if it has something to do with the new Mime Types file from 2.10 onward? --

Thanks!

  • Do you have XSS filtering on for file uploads? – Derek Hogue Feb 1 '16 at 14:59
  • I have tried it both on and off. – Percy Wang Feb 2 '16 at 19:04
0

Depending on version, creation software used, possibly OS, and a whole host of other variables, the actual mime-type of a file can vary. Some quick research show me that an EPS file may represent as these mime types:

application/postscript
application/eps 
application/x-eps
image/eps
image/x-eps

I would try adding these mime types one-by-one to your white-list array and hopefully one will cover it. Make sure to remove the ones that didn't work after.

| improve this answer | |
  • Thanks, I had already tried adding those mime-types, and it did not work. I also tried adding to the Apache mime file too. – Percy Wang Jan 29 '16 at 14:37
  • FYI those are set in the /system/expressionengine/config/mimes.php file – Jim Wyse Jan 29 '16 at 15:00
  • Yes. I had set them in the correct place. – Percy Wang Jan 29 '16 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.