0

Today I updated an old site from 2.2.1 to 2.10.3. I attempted to update some Add-Ons but ran into an issue with Wygwam. I downloaded Wygwam 4 from Devotee. Follow the update instructions but ran into errors. The first one below was easily solved as the add-on didn't have this define properly in the package.

This is how the file looks:

'wygwam_module_name' => WYGWAM_NAME,

'wygwam_module_description' => WYGWAM_DESC,

enter image description here

I got rid of that error.

Next I went to update the module and came down with this error:

Fatal error: Class 'PT\Wygwam\Helper' not found in /home/xxx/xxx.com/system/expressionengine/third_party/wygwam/upd.wygwam.php on line 27

Any tips on what might be going wrong here? Thanks!

1

The minimum required EE version for Wygwam 4 is EE 3.1.0, which is why you're getting the errors.

If you need to download an EE 2.x compatible version of Wygwam, you can via Devot:ee like so: https://twitter.com/devot_ee/status/695657856733990912

3
  • Legacy version was not available via Devot:ee, however we received a compatible version from P&T. Thank you! Feb 9 '16 at 0:50
  • Where are you getting this compatibility information? Their own installation instructions give a minimum version of EE 2.7 (thought those install instructions seem irrelevant to EE 2.x). Some clearer communication from P&T would be helpful here. Feb 29 '16 at 15:43
  • Sorry about that, updated the docs.
    – Brad Bell
    Feb 29 '16 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.