1

Thanks For Taking The Time To Read!

This has me a bit stumped: Error generates upon form submit.

  • Live Site
  • Checked several times for allowing comments in both System Settings & Channel
  • First Site with EE 3 (Core)
  • Used different emails/comment tests

Page Link: http://www.stevenseppinni.com/index.php/site/article_detail_video/this-is-a-video-example

<section id="comments">
          <h6 class="section-title">3 Comments</h6>
          <p>Comments are optional and I am editable! Whoop!</p>
          <ol class="comments-list">
{exp:comment:entries sort="desc" orderby="date" limit="20" dynamic="no"}
            <li class="comment">
              <article> {if avatar} <img src="{avatar_url}" width="{avatar_image_width}" height="{avatar_image_height}" class="avatar" alt="{author}'s avatar" /> {/if} 
                <div class="comment-meta">
                  <h5 class="author">By: {name} On: {comment_date format="%Y %m %d"} <a href="#" class="comment-reply-link">Reply</a></h5>
                </div>
                <!-- end .comment-meta -->

                <div class="comment-body">
                  <p>{comment}</p>
                </div>
                <!-- end .comment-body --> 
              </article>         
            </li>
{/exp:comment:entries}
          </ol>
        </section>
        <section id="respond">
        <div class="row">
          <div class="col-lg-12 col-md-12 col-sm-12 col-xs-12 blogleft contact">
{exp:comment:form channel="article_wistia_video"} 
              <h3 class="contactTitle">Leave a Comment</h3>
              <div class="row">
                <div class="col-xs-12 col-sm-12 col-md-12 col-lg-12 form-group form-row">
                  <input type="text" class="normal" id="name" placeholder="Name" name="name" value="{name}">
                </div>
              </div>
              <div class="row">
                <div class="col-xs-12 col-sm-12 col-md-12 col-lg-12 form-group form-row">
                  <input type="email" class="normal" id="email" placeholder="Email Address" name="email" value="{email}">
                </div>
              </div>
              <div class="row">
                <div class="col-xs-12 col-sm-12 col-md-12 col-lg-12 form-group form-row">
                  <textarea name="comment" placeholder="Comment" rows="4" class="normal">{comment}</textarea>
                </div>
              </div>
              <!--<div class="row">
                <label><input type="checkbox" name="save_info" value="yes" {save_info} /> Remember my personal information</label><br />
                <label><input type="checkbox" name="notify_me" value="yes" {notify_me} /> Notify me of follow-up comments?</label><br />
        {if captcha}
                <label for="captcha">Please enter the word you see in the image below:</label><br />
                <p>{captcha}<br />
                <input type="text" name="captcha" value="{captcha_word}" maxlength="20" /></p>
        {/if}
              </div> -->             
              <div class="row">
                <div class="col-xs-12 col-sm-12 col-md-12 col-lg-12">
                  <input type="submit" id="submit" name="sumbit" value="Submit" class="button">
                </div>
              </div>
{/exp:comment:form}
          </div>
          </section>
          </article>
        </div>
      </div>`
8
  • Hi there! Please describe the error in more detail. What kind of error is it? What is the error text? A screenshot of the error message can also be informative.
    – Alex Kendrick
    Feb 17 '16 at 16:56
  • Oh, I see the error is described in the subject. I must admit that for me it never registers (be it forum posts, emails, etc) when the key information only exists in the subject/title. Others might do fine with that, but I'd still recommend adding the error message itself to the body of your question.
    – Alex Kendrick
    Feb 17 '16 at 18:30
  • Hey Alex...thank you so much for your time and expertise.
    – Matt
    Feb 17 '16 at 19:18
  • No problem. Let me know if my answer didn't do the trick and I'll try to make another suggestion. If my answer solved the problem for you please accept it. See What should I do when someone answers my question? in the help center.
    – Alex Kendrick
    Feb 17 '16 at 19:23
  • Based on your reply, I tried to edit the member group settings for Super Admin and just allows me to edit the Name, Description and Member Lists. SO I created a new user group and setup the variables as per above, logged in and then when submitting a comment I get a blank screen...I tried the same "not logged in from another browser... Same: no error, no page load to redirect...now I get the following php notices when logging into SUper Admin Notice Undefined offset: 0 ee/EllisLab/ExpressionEngine/Controller/Members/Members.php, line 702 show details
    – Matt
    Feb 17 '16 at 19:25
1

One likely possibility to check first:

Make sure the Guests member group (which is essentially any non-logged-in users) have permission to post comments.

In EE2 you'd go to Admin > Member Groups > Guests and look for Comment Posting Privileges

Not positive, but in EE3 I believe this member group setting is called Submit Comments https://docs.expressionengine.com/latest/cp/members/groups/form.html#submit-comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.