1

ExpressionEngine 3.1.2

Channel Images 6.0.1

The addon installed ok. I have tried uninstalling and re-installing and had no change. The field was created ok. The location check passed. However, when I try to view the template, I just get 2 warnings and a fatal error.

Test Location Results

I understand that it says

Even if all tests PASS, uploading can still fail due Apache/htaccess misconfiguration

but I don't see anything wrong with either.

I am able to create an entry and upload the photos. I can see the images on the server. When I try to render a template, I get the following warnings and then fatal error:

enter image description here

Warning 1:

Warning

require(/home/stkhomes/system/user/addons/channel_images/locations//.php): failed to open stream: No such file or directory

user/addons/channel_images/models/channel_images_model.php, line 701 hide details

Severity: E_WARNING

Warning 2:

Warning

require(/home/stkhomes/system/user/addons/channel_images/locations//.php): failed to open stream: No such file or directory

user/addons/channel_images/models/channel_images_model.php, line 701 hide details

Severity: E_WARNING

Fatal Error:

Fatal error: require(): Failed opening required '/home/stkhomes/system/user/addons/channel_images/locations//.php' (include_path='.:/usr/local/php56/pear') in /home/stkhomes/system/user/addons/channel_images/models/channel_images_model.php on line 701

I stepped through things and it appeared that the cache was not being written and returned inside the CI model.php file.

Does anyone have any insight on this? I am on a deadline and this is a huge snag for me right now as I planned the site around this field.

2

OK,

Here is the last email to Himanshu with DevDemon support...

Hi Brian

Ok I have found the problem from your side . You have not set Caching driver disable but to work with Channel Images, you must set it to the "FIle". Now I have set it to file and it working perfectly. I have set dummy Channel , Field Group and Field to test on your server.

I have attached image to display the setting

thanks,

Himanshu


Himanshu,

Thank you for finding this. I have two quick questions.

1) I didn’t change anything on the cache settings. This was a blank install and then started loading things in. Is this a default setting for EE3 or could an addon have made that setting?

2) If this is a setting that has to be set proper for CI to work, should the addon either inform or lock this setting in EE’s CP? If not, should this be in the docs or at least issue a better error message?

Thanks,

Brian

Here is the image he attached...

Settings

| improve this answer | |
  • This solution worked for me when I was getting the same error message. It would be nice if this apparently crucial step were mentioned in the documentation. – edward Oct 25 '17 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.