0

I cannot get any queries to work using exp:channel:entries.

{exp:channel:entries orderby="date" start_on="2015-07-01 20:00" channel="shipments" limit="10" dynamic="no"}
<p>inloop</p>
{/exp:channel:entries}

Here is my query above. I have tried every combination of its option variables and nothing works. I cannot get any query to work for any channels except the one below,

{exp:channel:entries}
<p>inloop<p>
{/exp:channel:entries}

Which is just pulling out 100 entries.

This is a old site for a client that uses expressionengine only as a backend solution. Its V2.6.1 There are no other templates. I am not using file templates, only database. Is there some setting that restricts channels from being used in templates that I am unaware of?

  • You may find that the start_on parameter was not available in that version (I don't have the docs back that far). There is nothing that would prevent a channel tag from running in a template. That's what they were design for. Start with your loop that works and add parameters until it doesn't. Also try setting the show_future_entries parameter. – Jim Wyse Feb 19 '16 at 19:08
  • I have stripped away everything except for and when doing channel is when it breaks. Super weird. Just cannel. And dynamic. So this does not work, {exp:channel:entries channel="shipments" dynamic="no"} <p>inloop<p> {/exp:channel:entries} – David B Feb 19 '16 at 19:50
  • Actually it just seems to be breaking on 1 channel. Has anyone experienced this? – David B Feb 19 '16 at 22:20
1

The channel ended up having custom status types so the defaults were not working. I did not make this website so I did not realize this was the case.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.