0

I just went through the upgrade process from 2.7.2 to 2.10.3. Now when I try to login, the login page just refreshes. I've tried different browsers and restarting browsers. No error messages, just a page refresh. Anyone else run into this?

  • Normally it's a case of clearing browser cookies, but have you tried manually deleting the EE cache files in system/expression engine/cache? – Peter Lewis Feb 20 '16 at 9:15
  • Thanks, I'm familiar with the browser cookie bug. This seems to be related to something else. Haven't tried manually deleting cache files, I'll try that. I rolled back the update, tried it again, and got a white screen. Then I rolled it back again (to 2.7.2), updated all add-ons, and get the same page refresh behavior. I can finally login if I set $config['allow_extensions'] = 'n'. Must be something related to an add-on. I'll keep troubleshooting. – user7119 Feb 20 '16 at 22:24
  • Just a thought but does this site use MSM by any chance?? I've seen this behaviour before with an older 2.x site, where the admin session for SITE2 causes the login to refresh on SITE1. If you use MSM check you deleted the cookies from all the site domains. – Blatant Feb 24 '16 at 10:25
0

Assuming cookies and my MSM query above fails you, perhaps review some of the comments on this bug report : https://support.ellislab.com/bugs/detail/19334

It's for older versions but there's a few nuggets that will help you. For instance some people report login issues using Zoo Flexible Admin or Republic Analytics which are both extensions.

Also (from the link), might be worth searching your third_party directory or your exp_extensions table for extensions using the cp_member_login hook, will help you identify the culprit as you commented that disabling extensions fixed things up nicely...

Also, check our session domain and/or perhaps try juggling the Admin CP session type and check your $config['cp_url'] value.

Though, as you state it's probably down to an extension using the CP hook that is incompatible or something, just need to locate the offender. Let us know how you fare!

| improve this answer | |
  • There are some interesting tidbits in that thread and your answer above. I appreciate the leads. I suspect it may be something with Structure. If I can devote more time to troubleshoot it, I'll try to confirm that and get back to you. – user7119 Feb 26 '16 at 23:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.