0

Does anyone know if it's possible to get Wygwam to replace inch and foot marks (" and ') with apostrophes and proper, left and right curly quote marks? So Don't becomes Don’t and "This" becomes “this”? I think EE does this to titles, but Wygwam doesn't seem to... Thanks!

1

In your WYGWAM editor configuration setting, you need to add an advanced settings for “entities” and set it to no because WYGWAM encodes straight quotes as " which prevents any typography processing from working correctly.

entities setting

Then use something like Typographee to parse the typography correctly (this is what I do): https://github.com/tjdraper/typographee

(There is an EE 2 branch on the GitHub repo as well so it’s not EE 3 only)

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.