0

I am using an {exp:freeform:form} tag for contact requests and am getting this error when submitting the form in Google Chrome only:

"This form has expired. Please refresh and try again."

Because this is EE's CSRF protection error, I tried disabling CSRF protection in my config file and submitting the form. This works, but I dont' want to leave it off permanently.

$env_config['disable_csrf_protection'] = "y";

The odd thing is, why would this only happen in Chrome and not Firefox, Safari, etc.

Could it be a Cookie issue?

The site is using: EE 2.9.2 Freeform 4.2.0

1

ExpressionEngine 2.9.3 officially addressed and resolved some common issues with CSRF. I strongly suggest you upgrade to EE 2.9.3 or greater to resolve or rule out that issue. :)

"CSRF tokens stored in cookies refresh with page refresh." - ExpressionEngine 2.9.3 Change Log

| improve this answer | |
  • Thanks for the quick reply, I'll upgrade as soon as possible and post back with the results. – mjr Mar 4 '16 at 16:58
  • hmm...I upgraded EE to the latest version 2.10.3 and Freeform to 4.2.4 and am still experiencing the same issue in Chrome. – mjr Mar 14 '16 at 13:54
  • Is there anything else I can look into at this point after upgrading? – mjr Mar 23 '16 at 17:09
  • Can you duplicate this from another computer in Chrome? :) – Solspace Mar 23 '16 at 21:18
  • I've been able to duplicate this on another computer in Chrome. If my cookie is set for .example.com and the url is www.example.com could that cause any issues? – mjr Mar 24 '16 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.