0

Does anyone know about any resources that explain how to get EE2 to play nicely with SSL certificates please?

Thanks!

  • Could simply adding https:.//'to your general config > site settings field fix it? – stuartmcd69 Mar 9 '16 at 5:46
  • Sorry, typo.... https:// – stuartmcd69 Mar 9 '16 at 5:46
  • Then add htaccess rules to force everything to https – Jim Wyse Mar 9 '16 at 14:25
  • Tried both of those, all that happens is site fails to render properly; EE is sending stuff over https: but the results in the browser are a total mess. I can work through and debug, but rather hoped I'd missed something obvious that would avoid the need to go through asset by asset to work out what is going wrong. – JCOGS Design Mar 9 '16 at 14:31
1

My general steps are:

  1. Set up General Configuration > URL to the root directory of your site to use https.
  2. Set up File Upload Preferences > > URL of Upload Directory to use https. This makes sure your images/documents are properly linked.

To catch any other http references:

  1. View source of your web page and search "http:".
  2. Search for "http:" in your file tree (grep -r 'http:' /path/to/ee/root).
  3. I've never had to go this far, but Developer Tools > Network might shed light if some something embedded deeper is making http calls.
| improve this answer | |
0

Sussed it out - a couple of EE Addons had been set with hard-wired base URL entries that I had missed - so when I set it to HTTPS operation, they continued to serve items using the hardwired (non HTTPS) URLs. One of these was Minimee and so none of the style sheets or js loaded due to insecure content.

| improve this answer | |
  • Could you mention the apps that require a bit of a tweak? – Holland Mar 22 '16 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.