0

After upgrading to 2.10.3, my client can no longer upload anything via the File Manager - not even a vanilla 24kb jpg.

"File not Allowed" appears in red letters in the modal window where the file is chosen.

I've double-checked the mime type locally:

199701AD.jpg: image/jpeg; charset=binary

And this is obviously in-line with EE's default settings for allowed files.

I've noticed that the file is thrown away and the error is thrown after the file is uploaded. I've tried a variety of files, all have the same result. The upload directory permissions are 777 (for the purposes of debugging this.)

  • does the file open OK locally in Photoshop or similar? – Steven Grant Mar 21 '16 at 16:04
  • Are the permissions for the thumbnail directory the same? You using GD or ImageMagick to create thumbnails? – John Henry Donovan Mar 21 '16 at 16:05
  • @StevenGrant - yes the file opens great everywhere, is about as normal and un-special as it gets. – Petroglyph Creative Mar 21 '16 at 20:28
  • @JohnHenryDonovan It had not been, but now that it's also 777 I am not noticing a change. – Petroglyph Creative Mar 21 '16 at 20:31
0

File Info for 2.10.0

Apparently an entire config file had changed format (mimes.php) for version 2.10.

I'm not entirely sure how I didn't overwrite the old one, because this should have happened in at least 1 of my fallbacks, but I had the old one so technically no files were whitelisted.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.