2

I'm trying to install EE 3.2.1 on localhost on my Mac. But I'm getting the following 'undefined function' error. Through Google I can't find any mention of anyone else having the same issue. What might be the cause?

Call to undefined function EllisLab\ExpressionEngine\Service\License\openssl_verify()
in /Users/xxxxx/www/iffa/system/ee/EllisLab/ExpressionEngine/Service/License/License.php on line 248

My system versions are: Apache: 5.5.31 mySQL: 5.6.25

3

openssl_verify is a PHP function, so you need to install it for PHP, normally it's installed as standard, so guess you're using an abnormal PHP installer...?

Here's a reference to a bug report that was created.

It may be as simple as you've not got the php.ini module line uncommented:

extension=php_openssl.dll

PHP OpenSSL Installation reference.

| improve this answer | |
  • Thanks Peter, I was able to install the openssl extension and all is good now. – Craig Allen Mar 29 '16 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.