0

EE v2.10.3

Freeform Free 4.2.4

Having trouble creating new fields.

When I hit the "New Field" button I get the following errors...

    A PHP Error was encountered
Severity: Notice
Message: Undefined index: checkbox
Filename: libraries/Freeform_fields.php
Line Number: 246

A PHP Error was encountered
Severity: Notice
Message: Undefined index: checkbox_group
Filename: libraries/Freeform_fields.php
Line Number: 246

A PHP Error was encountered
Severity: Notice
Message: Undefined index: country_select
Filename: libraries/Freeform_fields.php
Line Number: 246

A PHP Error was encountered
Severity: Notice
Message: Undefined index: hidden
Filename: libraries/Freeform_fields.php
Line Number: 246

A PHP Error was encountered
Severity: Notice
Message: Undefined index: multiselect
Filename: libraries/Freeform_fields.php
Line Number: 246

A PHP Error was encountered
Severity: Notice
Message: Undefined index: province_select
Filename: libraries/Freeform_fields.php
Line Number: 246

A PHP Error was encountered
Severity: Notice
Message: Undefined index: radio
Filename: libraries/Freeform_fields.php
Line Number: 246

A PHP Error was encountered
Severity: Notice
Message: Undefined index: select
Filename: libraries/Freeform_fields.php
Line Number: 246

A PHP Error was encountered
Severity: Notice
Message: Undefined index: state_select
Filename: libraries/Freeform_fields.php
Line Number: 246

A PHP Error was encountered
Severity: Warning
Message: Cannot modify header information - headers already sent by (output started at /path/to/public_html/system/codeigniter/system/core/Exceptions.php:170)
Filename: core/Common.php
Line Number: 475

The Field Type select box is also populated with php errors.

I have tried a fresh install of the addon too, by removing the existing system + theme folders and uploading fresh.

Thanks

0

It sounds like something didn't get installed correctly. Check and see if the exp_freeform_fieldtypes table was created and populated.

Edit: It looks like Freeform "Free" was installed over a previously installed Pro version and the fieldtypes table contained all the Pro fields which the Free version does not use. Removing the extraneous rows from the fieldtypes table resolved the issue.

8
  • Seems to be there, populated. See attached file. Field ID's 1-4 have a different version though and do not appear to be included in the PHP errors. i.imgur.com/jpAHix4.png – Mark Mar 30 '16 at 17:01
  • Any other ideas? I need to resolve.. (Being chased) thanks for any help – Mark Apr 2 '16 at 8:12
  • Not sure what went south for you. First un install Freeform from the module control panel. Delete all the files from your third party folder. Delete all the freeform database tables. Make sure there are no freeform references in the actions, modules, and extension tables. Then install again. That's about all the advice I can give you with out getting into your CP and server. – Jim Wyse Apr 2 '16 at 12:32
  • I can give you access if that would help. I have many form fields and submissions that I need to keep – Mark Apr 2 '16 at 14:49
  • What's your email address? – Jim Wyse Apr 2 '16 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.