0

I have created a restricted user group for external bloggers; I want to be able to prevent them from uploading images via Assets, but I'm not sure how. I've restricted access to the Assets module for that particular user group (in Module Access Privileges), so while they can't access it directly, it still appears when they click on the image icon in Wygwam.

Regardless, they have full access to the content of Assets, including the ability to upload.

How do I restrict this? Ideally they wouldn't have access to Assets at all, but if I could keep them from uploading, that would be OK as well.

Currently running EE 2.7.2, with Assets 2.1.4 and Wygwam 3.2.1

  • For external bloggers, do they post in their own restricted channel? If so, you can create a different field group for that channel, and a custom Wygwam field that doesn't have the image button available. – jrothafer Apr 4 '16 at 23:03
  • If it were only the external bloggers that had access to that channel, that would work great. Though I do have some internal users that would be posting to that channel as well, and they will want access to Assets. – Lane Denson Apr 5 '16 at 18:33
0

Oh right, this is an easy one. You won't be able to take away the button in Wygwam for this solution as your regular editors need it, but the answer is a no brainer. You need to edit your File Upload Preferences.

EE2 Docs

EE3 Docs

Simply change the privileges for your guest bloggers' Member Group for all upload paths.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.