0

I'm using EE 2.8.1 and I just updated Wygwam from 3.3.1 to 3.3.3 by copying over system/expressionengine/third_party/wygwam and theme/third_party/wygwam folder contents over, then running "run module updates"

Everything seems to work, but my icons are all messed up. For example, the icon that is clearly for unlinking (the chain with the x on it) is now the icon for linking. And the one for unlinking looks like bullet points. And the one for inserting a "read more" break in the text looks like the text unformatting icon (the T with an x at the bottom).

I didn't know what to do so I restored my OLD themes/third_party/wygwam folder from a backup, and now everything looks okay. But I kept the changes I had made on the system/ folder. Ideally I wouldn't want to keep it this way, since the themes folder is the old version... but it seems to be working... but maybe there are some undetected problems from doing it this way. Any help or suggestions?

0

Eventually this is an issue of the CKEditor version which comes with Wygwam 3.3.3 Old CKEditor version often are not compatible with some browser-updates. I remember in 11/2014 I had a similar issue with Safari 7; I had to beg and wait until P&T updated the CKEditor in the new 3.3.3-release (you can't just update the CKEditor yourself).

So I would recommend:

  • Update to Wygwam 4.0.1 - it comes with CKEditor 4.5.7 (instead of 4.4.6 in your Wygwam3.3.3-version which is from 12/2014). I would expect your problems to disappear.
  • You also could try to view your backend with a different browser. There is a slight chance that this fixes the problems.

Oh ... And for sure you did empty your browser-cache, deleted cookies etc.? :-)

4
  • Yeah it was still showing the old icons (correct ones) until I emptied my browser cache.. then it showed the incorrect icons. And I can't update to Wygwam 4.0.1 because i'm still on EE2. Many of the plugins the site relies on are not on EE3 yet, so I will have to remain on EE2 until they catch up. – dcplebranch Apr 8 '16 at 13:42
  • Yes, it's the same issue for me. But I remember that the PT-Support told me that it will not be possible to integrate a new version of CKEditor manually into an old Wygwam-release. So you have got to switch WYSIWYG-Editor or update EE :-/ – BNetz Apr 9 '16 at 10:47
  • Thanks @BNetz . For now, I can't upgrade to EE3 because my site depends on too many modules that only work in EE2. – dcplebranch Apr 18 '16 at 14:45
  • Well perhaps you should try another solution - Wyvern ( devot-ee.com/add-ons/wyvern ) comes to my mind. Once I did use it but replaced it by Wygwam - sadly I don't remember the reason why. – BNetz Apr 18 '16 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.