0

Is there someone that can explain this to me. I call exactly the same page from same IP in 2 different devises but the formatting of the date is different.

This is the Template code:

 <p>{utstal_datum}
        Utställning pågår från {utstal_datum:begin format="%l %d %F %Y"} till {utstal_datum:end format="%l %d %F %Y"},<br>
        <b>vernissage: {utstal_datum:vernissage format="%l %d %F %Y"} {klockslag}, välkommen!</b>
        {/utstal_datum}
    </p>

Thanks for looking at this.

Screenshot iPad (Swedish language and region): enter image description here

screenshot Macbook (Swedish language and region):enter image description here

To my opinion this is not a duplicate. The locale on the server is correctly set to Swedish. And as you can see from the screenshots, one of the devices shows the right formatting, the other not.

4
  • At a guess (hence not a proper answer): The format parameter on a date field is actioned and processed server side, and as I'm sure both these are from the same server, the issue isn't going to be your code or the EE build. I expect the difference could be what your browser is sending as the language which EE date format is using. Your website is built with Swedish content, so obviously isn't controlled by browser settings. Check your browser default language (try other browsers on the Macbook). For Chrome it's Settings -> Advanced -> Languages -> Language & Input Settings. Apr 13 '16 at 19:31
  • Reading the docs: docs.expressionengine.com/latest/templates/… It will utilise the control panel language format or logged in user format. Were you logged in on the Macbook? Apr 13 '16 at 19:36
  • Already asked before: expressionengine.stackexchange.com/questions/223/… Apr 13 '16 at 19:36
  • Hi Peter, thanks. I checked again with Safari on my Macbook, logged in as user_1. Formatting in English. Logged out, formatting in Swedish. I accept your answer no 2. So, I must do something about the language settings, I thought I had them default set on Swedish for all new users.
    – Hansl
    Apr 14 '16 at 5:10
1

Reading the docs, it will utilise the control panel language format or logged in user format. Were you logged in on the Macbook?

Similar question and alternative answer for multi-language: How do I format the date in a foreign language?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.