0

I have the Solspace importer module working well using DataType: CSV Importer. However it won't import data into a custom field past a £ character. For example:

Data to import: Price Guide £300,000 - £315,000

After import, field contains: Price Guide

I've tried using both None and XHTML text formatting for the custom field.

Am I missing any settings? or do I need to encode characters before import?

(EE 2.10.1 and Importer 2.2.5)

0

It is required that the .CSV file match the encoding of your data table. Most likely this is UTF-8.

My workflow with Importer includes the step where I open the .CSV file in a text editor (I use BBEdit) and save the file as UTF-8 and Windows Line endings (CRLF).

  • 1
    Thanks! Yeah, the file in question was 'Windows Latin 1'. As this is a daily import process I contacted the webhosts to automate the conversion of file encoding. – user1365655 Apr 19 '16 at 10:09
0

guessing here, but it might be something to do with allowed characters.you'll have to search what file/setting to set that, cause i don't remember

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.