0

I have an issue with creating and deleting field types ,its takes a really long time to do both and sometimes the site times out and when I get back in the field is only half created.I can then save the field again and it will take around 3 minutes to process through the database. At the end of the day i can create a field but it is taking too long and I want to know whats going on with the database that is causing that delay .I am running EE 2.9.2 and have no other issues with EE as everything else runs fast. Thanks in advance for any help or advice

3
  • How large is your database? Also, how many rows and columns are in your exp_channel_data table?
    – Anna_MediaGirl
    Commented Apr 19, 2016 at 20:44
  • And what's your hosting situation?
    – AllInOne
    Commented Apr 20, 2016 at 14:03
  • I have dug a little more and it seems to relate to my database size , i have 10,000+ entries and looking at the mysql process the slow down seems to stem from the the actual size of the database.The new fields I add are created properly but there is a around a two minute delay in the process. Im not sure if there is anything that can be done about this
    – bhackett
    Commented Apr 21, 2016 at 15:07

1 Answer 1

0

Ok I decided to update to the latest version 2.11.1 and i was looking through the change logs and I saw this on the 2.10 change log

Added -Optimized queries used in new channel field creation.

So I went ahead with the upgrade and it has greatly improved the field creation time

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.