0

I am running Updater 3.3.0 with php5.6 and get these errors:

Message: Non-static method Updater_helper::arrayExtend() should not be called statically, assuming $this from incompatible context Filename: updater/api.updater.php

If I make the functions static the error messages in the Control Panel go away, but Updater throws more errors when I try to run it and update EE from 2.10.1 to 2.11.1.

Does DevDemon Updater 4.0.0 run on php5.6 without these errors?

1
  • To rephrase the question, what versions of PHP will DevDemon Updater 4.0.0 run on?
    – C Thomson
    Apr 20, 2016 at 14:56

1 Answer 1

0

I think you have to use updater 3.3.0 to run on EE 2. I'm having the same problem with Updater 3.3.0 on EE 2.11.1. I just moved a site from another host to a new host with some of my other sites which were on PHP 7, and I've had to move that new host down to PHP 5.5 to stop Updater throwing those errors. I'd like to move these sites back up to PHP 7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.