0

EE Version 2.10.1, PHP 5.3.27 Neither have been updated since installed. And as much as I would LOVE to upgrade to EE v3.x, I cannot due to some of the Add-Ons not having been upgraded.

This appears to have something to do with ExpressionEngine’s query functionality. I uninstalled the Query Module and reinstalled it, but the same issue.

Just started to receive this error about 2 hours ago. I have looked all over ExpressionEngine but cannot figure out what the issue is EXCEPT that when I use the following in PHP within the Template, it causes the above error:

$uploadTo = $this->EE->db->query( “SELECT server_path as url FROM ” . $prefix . “upload_prefs WHERE 1 = 1 and name = ‘ABC’ “);

Hmmm, it appears to be the same issue if I use the following:

{exp:query sql=”select Count(*) TheCnt from EE->db->dbprefix; ?>FrEd fred Where 1=1 and fred.ID = EE->session->userdata(‘member_id’); ?> and fred.CanDt is NULL” } {/exp:query}

1

The issue was that the Hosting Provider had enabled mod_security in the middle of the day (right when I had taken a slight break) without notifying me of this ahead of time.

They disabled mod_security late last night and all is working correctly now.

BTW, the error_log file on the hosting site had all sorts of errors notifying that the issue was mod_security.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.