4

I've recently migrated a site, and now when uploading pictures through the file manager in Wygwaym images large enough to require a thumbnail cannot be uploaded, very small images, however, can be. I've verified that the _thumbs directory exists, and has the correct permission. As noted in some old EE Forum threads, I've also ensured that the server user that created the folder and the one the site runs as are the same.

Any thoughts?

  • Are there any error messages anywhere? Have you checked the Chrome Network tab & javascript console etc? – Adrian Macneil Jan 12 '13 at 2:19
  • That is the error message displayed by EE, no other errors are being displayed either in EE or in the browser. – Jacob Russell Jan 12 '13 at 2:24
  • Are there any errors in Apache's error log related to it? – Brad Bell Jan 13 '13 at 4:03
  • There is the http://www vs http:// issue which tends to screw up path values. In General Configuration settings, are the paths relative or absolute (e.g. "/root/path/to/themes/" rather than "http://example.com/themes/")? This has caused problems with file uploads with Wygwam in Safari previously. – Holland Jan 13 '13 at 8:29
  • Paths are set relatively static. By that I mean my config uses server variables to build full paths and urls. I don't think that's what's going on here, sadly. – Jacob Russell Jan 15 '13 at 3:46
3

I was able to fix a similar problem on a different site.

First, make sure the thumbnail directory has write permissions. The command I used was something like "chmod -R 777 expressionengine/cache"

Second, take a look at the Image Resizing Preferences in the admin:

  1. Go to Admin-> System Administration-> Image Resizing Preferences

  2. Set Image Resizing Protocol to ImageMagick.

  3. Set the Image Converter Path to the location of the ImageMagick binary. You can find the path by running "which convert" on the server command line. If it doesn't show a path, then then you need to install ImageMagick on the server. In my case the path was "/usr/bin" but another common location for it is "/usr/local/bin".

I hope this helps.

| improve this answer | |
2

Make sure the directories are web-user writable and are owned by the systems' webuser. Check the ownership of files uploaded through the control panel to images - often it's a www-data:www-data pair.

| improve this answer | |
  • The upload directory and the thumb directory are 777. The ownership of files uploaded by the site is the same as the user who owns all the files / folders. Both of those would have made sense, but sadly not the issue here. – Jacob Russell Jan 12 '13 at 16:18
2

Could be you need to increase the limits for PHP to allow enough memory to create the thumbs.

Have you tried amending php.ini?

| improve this answer | |
  • 1
    Please expand on your answer by documenting how to amend the php.ini file as you are suggesting instead of asking a question. – Anna_MediaGirl Jan 14 '13 at 1:25
  • That's not a good option here, and I don't think the cause. Memory is at 32M right now, and this is the same site and server that I've recently posted about crashing due to a memory and then load spike. So I've got other issues that increasing memory would potentially make worse. – Jacob Russell Jan 15 '13 at 4:02
  • I had to increase memory_limit in php.ini to 256MB for file uploads using file field in a exp:channel:form, although in the CP it worked OK when the memory was just 32MB. – Samsull Nov 26 '13 at 23:43
1

I had this problem and what fixed it for me was changing the Image Resizing Protocol to GD2 (it was set to ImageMagick, which probably was not installed on this server). Image Resizing Protocol (in EE3.5) is in Settings > Content and Design.

So in other words, make sure the Image Resizing Protocol is set to what is installed on your server.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.