4

Hello fellow ExpressionEngineers,

I'm in the process of translating the website of one of my companies. It was made in french and I'm doing the english language translation. For that job, it seemed like the rather new EEHarbor's Transcribe module was fit for the job. I think I've got a pretty good understanding of how it should work. The problem is that I can't make it show the proper channel entries regarding the current language. It will always show all entries for the channel no matter if they are in french or in english.

To give you a little background, EE install is 2.5.5, and I'm not using a lot of modules/plugins : NSM Better Meta, NSM Morphine, NSM Live look, NSM Bootstrap, Wyvern, Low Seg2Cat, Detour, Entry Lottoree, Minimee. Nothing too fancy and all up to date.

Following is an example of one of my channel tags :

{exp:channel:entries channel="features_at_glance" dynamic="no" order_by="date" sort="asc" limit="4" {global:param_disable_default}}
<li>
<div class="inner">
<h4 style="background-image: url('{site_url}{feature_at_glance_icon}');">{title}</h4>
<p>{feature_at_glance_content}</p>
</div>
</li>
{/exp:channel:entries}

{global:param_disable_default} comes from NSM Bootstrap and is replaced by disable="categories|pagination|member_data".

I have tried removing every params from the channel without any success. It's still showing every entries for the channel even if you are supposed to view the english version of the website.

Transcribe is configured like so:

Settings

  • Default language: French
  • Add language prefix to URL: Defined per language
  • Transcribe enabled: yes

Languages

French has "add language prefix to URL" set to "no" while english has it set to "yes" (French being the default language, I obviously don't want it prefixed for SEO reasons).

Also, please note that I have also var dumped some var like language_id in Transcribe source code to verify that the proper language was being used and I was able to confirm it was at least correctly detected.

Any ideas what I'm doing wrong?

Thanks!

  • I'm curious if you add transcribe="disable" to your channel entry tag if it still outputs both languages. Also, just to be sure, are you using the fr and en in your urls to make the switch or what are you doing to switch between the two langages, can you add that to your question just for clarification sake? – Natetronn Jan 13 '13 at 4:14
  • I have edited the post for clarity. Also tried what you suggested and that doesn't change anything. – Matt Jan 13 '13 at 4:37
  • 1
    Not sure you can or not though, I wonder what would happen if you disabled all your extensions (maybe mods as well) one by one to see if there is a conflict with one of them and Transrcibe. – Natetronn Jan 13 '13 at 4:55
  • I've done some debug by looking at Transcribe code and queries output from Profiler and made some progress: if the global channel setting "Cache Dynamic Channel Queries?" is on "Yes" the Transcribe code that modify the query to grab the correct entries related to the current language will never get triggered. After disabling that I can't now see the modified queries in the Profiler but unfortunately it still shows the entries from the wrong language (like it's actually discarding the results from the Transcribe query...). – Matt Jan 13 '13 at 6:33
  • 1
    Disabled EEHive Entry Lottoree and it's now working as expected. So disabling that extension on changing that global preference setting did the trick. I unfortunately cannot answer my own question to close this topic since I'm too new on the site. – Matt Jan 13 '13 at 6:47
2

I've finally figured out what was wrong :

First of all for Transcribe to correctly work it looks like, at least for my install, that the setting "Cache Dynamic Channel Queries?" from "Global Channel Preferences" must be set to "No".

Then you need to figure out the extensions that are using the "channel_entries_query_result" (a search in the exp_extensions table does help). In my case the EEHive Entry Lottery extensions was creating the problem. I have yet to figure out why...

| improve this answer | |
  • Great! Please make sure to select your answer as correct by clicking on the checkmark to the left of the answer. There may be a time delay before you can do this. – Anna_MediaGirl Jan 13 '13 at 19:05
0

It sounds like your channel short name may not be correct. Try a copy and paste to be sure the channel short name is correct.

| improve this answer | |
  • Thanks for the answer, but the channel shortname is correct. Like I said, the problem is that for some reason Transcribe is not filtering out other language entries... but entries do show up! – Matt Jan 13 '13 at 3:54
  • When I've seen "every entry" show it's been because the channel shortname wasn't correct. Do you mean that it's showing every entry for this channel or all entries from all channels? – Anna_MediaGirl Jan 13 '13 at 4:22
  • I have edited the post for clarification. It's showing every entries for a given channel, not for all. – Matt Jan 13 '13 at 4:35
  • Got it. That renders my answer irrelevant. – Anna_MediaGirl Jan 13 '13 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.