2

Earlier today, I updated my site to Matrix 2.5.2 and now, I'm getting white screens on all sorts of channel entries that have a Matrix field.

I get white screens inside the CP when I edit an existing entry that has a Matrix field and also when I view that entry on the front-end.

I do not get white screens when I go to publish an entry in a channel with a Matrix field.

To verify that it was, indeed, Matrix causing the issue, I pulled up an entry that did not have a Matrix field. I then added a Matrix field to its channel, and got a white screen. Removing the Matrix field returned the normal, expected behavior.

FWIW, I am using ExpressionEngine v2.5.5 with 64M of memory in PHP.

2
  • 1
    It’s either going to be a memory issue (as Anna suggested) or a PHP error. If it’s the latter, setting $debug=1; in your index.php/admin.php file (however you’re currently accessing EE) will reveal it. Commented Jan 13, 2013 at 19:55
  • 1
    I elaborated a bit on my previous comment on the white-screen-of-death tag’s wiki: expressionengine.stackexchange.com/tags/white-screen-of-death/… Commented Jan 14, 2013 at 5:56

2 Answers 2

3

Is it possible that you've uploaded the files and not visited Add-ons > FieldTypes > Matrix? You'll need to visit those fieldtype settings to run the database updates.

There is a GetSatisfaction question with some additional information on this, might need to re-enter the license key as well.

2
  • Just to be doubly sure, I went back and re-uploaded all of the files (in case I had somehow missed something) and then made sure to go to the "Matrix" page in "FieldTypes". Problem solved. Commented Jan 14, 2013 at 23:16
  • Awesome! Glad to hear it Jason. :)
    – Lisa
    Commented Jan 15, 2013 at 3:50
0

White screens in ExpressionEngine pretty much always mean there is a memory issue and I'm fairly sure this is the case for you after your upgrade. It sounds like you have large images stored in these Matrix rows. You can confirm that a memory error is the cause by looking at your PHP error log.

You can increase your php memory a couple ways depending on what your web host allows:

  1. Increase the memory_limit = 96M variable in your php.ini file
  2. Add php_value memory_limit 96M to your .htaccess file
  3. Add ini_set('memory_limit', '96M'); to your config.php file or the main matrix module file

You'll need to increase the memory number until the white screen goes away. Then I'd suggest reuploading images with smaller file sizes if this isn't a daunting task and reducing the memory back to your normal level.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.