0

Does anyone know how to clear the cache to be able to make changes to the email templates and have them update immediately? Right now, the templates are caching and changes don't show in the actual sent emails unless I create a new template and update the Action.

Also, how can I get access to the Member info from within the email template? For example, we want to confirm the username and email address they registered with, but the standard {username} and {email} tags doesn't work.

Thanks in advance, Justin

0

Are the {username} & {email} tags wrapped within something like this:

{exp:subs:subscriptions hash="{subs:subs_hash}" status="ALL"}
  {exp:member:custom_profile_data member_id="{subs:member_id}"}
      Member ID: {member_id}<br>
      {member_group}
  {/exp:member:custom_profile_data}
{/exp:subs:subscriptions}

The above works in my templates.

| improve this answer | |
  • Fantastic, thanks - this is exactly what I needed for the second part of my question. Using {email} within the exp:member:custom_profile_data didn't work though - what appeared in the emails was ".(JavaScript must be enabled to view this email address)" for some reason... but the way I'm using it was able to use the {screen_name} variable which renders just fine. If anyone knows about how to clear the template cache, please still let me know. – JustinXyn Jun 17 '16 at 16:46
  • Oh yes! I did encounter the problem with javascript interfering with the email address. I couldn't find a way around it though. As for caching, I remember encountering something like that, but can't remember how I got around it now. Are your email templates set to cache in the first place? – Xiao Ling Jun 17 '16 at 18:48
  • No, template caching isn't on - these email templates are the only ones that do this. And clearing "all caches" through the EE control panel doesn't help either. – JustinXyn Jun 17 '16 at 22:49
  • Sorry I can't be of more help. I recall that sometimes the email templates took a while to update, but couldn't find the root cause. – Xiao Ling Jun 20 '16 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.